Ledger Nano S - update problem

I just got my new Ledger Nano S. I tried to update it from 1.3 to 1.4 firmware. I followed the complete instructions from Ledger, but the Ledger is stuck on "update".
What can I do to finish the update?

There's a recommended fix here but I haven't tried/experienced it personally https://steemit.com/ledger/@cryptogeek1/ledger-nano-s-update-1-4-improvements-stuck-on-update-fix

Good luck!

Servers are probably experiencing heavy traffic since these are relatively the first moments since the update was launched. This could be the reason why you are experiencing difficulties/delays. Try updating your device again after a few hours. https://support.ledgerwallet.com/hc/en-us/articles/360002731113-How-to-update-the-Ledger-Nano-S-firmware

I recommend throwing the Ledger away. I've used a Ledger Nano S since March 2018 and its been very buggy. Counter Value not updating, app will not recognize device when connected on multiple platforms and machines to name a couple issues. Toss that one in the trash and get a Trezor save your time and sanity.

Log in to reply

Enjoyed this post? Consider registering for more interesting content!